Tuesday 1 October 2013

Suggested revision to savecontent

I like that <cfsavecontent> is available in CFScript now, but I dislike the clunky way it's been implemented.

The tag version is like this:
<cfsavecontent variable="content">
    <!--- stuff goes here --->

And the CFScript implemented is a fairly leaden transliteration of that:

savecontent variable="content" {
    // stuff goes here

I'm sorry, but this:

is just rubbish.

The construct ought to be:

content = savecontent {
    // stuff goes here

That would make more sense, yes?

I think Adobe just took the most expedient route in their handling of <cfsavecontent> in CFScript, and didn't really think through what would be most in-keeping with how scripting code generally works.

What do you think?

I've raised an E/R for it: 3643125. And, hey... if you think this is a good idea: make sure to go vote for it.