G'day:
A while back I raised this ticket with Adobe: 'List member functions should all be prefixed with "list"'; it's kinda self explanatory, but the gist is they'd implemented list member functions (good), but changed the names of the member functions to no-longer match their headless function counterparts. So the member function version of
listAppend()
was just append()
; listEach()
was just each()
.I figured this was of dubious merit as it muddied what was a list-oriented member function and what was simply a string-oriented one (
.append()
could just as easily do a string-append as opposed to a list-append), and this notion got a lot of support: "Survey results: lists in CFML, and the naming of list member functions".Credit where it's due, Adobe marked it to fix, and indeed "fixed" it before release of ColdFusion 11. So now we have
myList.listAppend()
, myList.listFind()
, etc. But we still have myList.changeDelims()
, myList.each()
and a few others haven't got their list prefixes.I duly raised another bug to cover this, yesterday: "
listChangeDelims()
member function missing".Today Rupesh simply closed this ticket as "Closed/Withdrawn/NotABug", offering this insight:
delimiter is meaningful only for list and therefore there is no ambiguity on this. That is the reason the list methods dont need any separate qualification.Honestly? Sigh.
list.changeDelims() is better than list.listChangeDelims()
Same is the case for map, each and filter methods. They apply only for collection and I don't see any ambiguity there.